Tue Aug 16, 2022 10:25 pm
Login Register Lost Password? Contact Us

Please Note: The HPCC Systems forums are moving to Stack Overflow. We invite you to post your questions on Stack Overflow utilizing the tag hpcc-ecl (https://stackoverflow.com/search?tab=newest&q=hpcc-ecl). This legacy forum will be active and monitored during our transition to Stack Overflow but will become read only beginning September 1, 2022.

REAL-BI - npm assorted errors on install

Questions around writing code and queries

Fri Feb 11, 2022 3:13 am Change Time Zone


I'm in the process of installing REAL-BI.
I've followed the instructions for the Docker installation.

In Windows 10 I get the errors that I attach to the post.
In Ubuntu 20.04 some other errors I also attach.

What they seem to have in common is that they come from the API container and seem to be related to npm and not finding some file or script to execute.

I'll really appreciate any clarification and help on how to move on with this installation.
The developer intricacies are way above my understanding, and so I'm a bit (in fact completely :shock: ) lost at this point.

I also attach my configuration files (.env renamed to .env_forum and docker-compose.yml), in case I'm doing something very wrong and accidentally triggering the errors.
If you need any other information/files please let me know.

Thank you very much!!!
Warm regards
(5.71 KiB) Downloaded 37 times
Posts: 25
Joined: Mon Nov 29, 2021 2:40 pm

Fri Feb 11, 2022 1:29 pm Change Time Zone

Hi Ricardo,

We just noticed this post of yours. Looks like this is from last year. Please let us know if you are still having issues. In the meantime, we'll try to reproduce this at our end

Posts: 7
Joined: Fri Mar 21, 2014 7:14 pm

Fri Feb 11, 2022 1:34 pm Change Time Zone

Hi Jerry,
Glad to hear from you!

Oh no, the post is from yesterday late night, or today's early morning :D ( Fri Feb 11, 2022).
Let me know if I can provide any other information.

Thank you!!!
Posts: 25
Joined: Mon Nov 29, 2021 2:40 pm

Fri Feb 11, 2022 1:42 pm Change Time Zone

Sorry, my bad. I was looking at the "Joined" date :-(.

We'll look into this issue and get back to you today
Posts: 7
Joined: Fri Mar 21, 2014 7:14 pm

Fri Feb 11, 2022 8:22 pm Change Time Zone

Don't worry at all, it happens to all of us ;)

An update:
While waiting for your answer, I tried a local installation in a new Linux server.
I'll show you the sequence of events according to the instructions: I generated a log for each step I could.

1. Run git clone https://github.com/hpcc-systems/REAL-BI.git to copy the project into your computer.

2.You will need to intall dependencies for a project. While in a root folder run command npm install, it will install npm packages in root as well as /api and /client folders.
Return: No such file or directory
So it's assuming you already have npm installed.

Next: apt-get install npm

3. In the root folder, rename the .env.example file to .env and fill in the empty values. You can find an explanation inside .env.example.

4.In /client rename the .env.example file to .env.development and fill in the empty values. You can find explanation inside .env.example .

5. Create real_bi schema in your local MySQL database.
Done- User admin

6. Go to /api and run npx sequelize db:migrate to build database tables.
It generates an empty log file (it writes nothing to the log file) but on screen it shows the following.

Code: Select all
[email protected]:/HPCCSystemsTools/REAL-BI/api# npx sequelize db:migrate > npx_sequelize_migrate.log
npx: installed 21 in 4.375s
command not found: sequelize

and I had to do this:

Code: Select all
npm install --save sequelize
+ [email protected]
added 17 packages from 83 contributors and audited 293 packages in 4.047s

57 packages are looking for funding
  run `npm fund` for details

found 6 moderate severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details

and this

Code: Select all
[email protected]:/HPCCSystemsTools/REAL-BI# npm install -g sequelize-cli
/usr/local/bin/sequelize -> /usr/local/lib/node_modules/sequelize-cli/lib/sequelize
/usr/local/bin/sequelize-cli -> /usr/local/lib/node_modules/sequelize-cli/lib/sequelize
+ [email protected]
added 71 packages from 50 contributors in 5.326s

And only then it runned .... but:

Code: Select all
[email protected]:/HPCCSystemsTools/REAL-BI/api# npx sequelize db:migrate > npx_sequelize_migrate.log
ERROR: Error reading "src/config/database.js". Error: Error: Cannot find module 'dotenv'

End of the road for me!

Again, I might be messing up with something, in which case a take full responsibility for my ignorance because although I am an IT person, I'm not a developer, and many of these things are beyond my understanding.
But being a tool intended for non-technical people the installation shouldn't be this stressing.

I'm open to understanding whatever I need to, to make this work, but my friendly suggestion would be to polish/simplify this installation process a bit, to make it more friendly and not so depending of everything being already installed, and aligned for this to work, or having the skills to fill all the gaps between the instructions and the reality. :D

And again, thank you very much!!
Warm regards!
(3.13 KiB) Downloaded 36 times
Posts: 25
Joined: Mon Nov 29, 2021 2:40 pm

Fri Feb 11, 2022 8:34 pm Change Time Zone

Hi Ricardo,

We looked into the docker issue you faced and it looks like the DB_HOST is the root cause of the issue. When RealBI is setup as Docker containers, the DB_HOST value has to be 'db', which is the name of the database service in docker-compose.

https://github.com/hpcc-systems/REAL-BI ... xample#L33

If you see errors connecting to MySQL database, please make sure the /db/data folder is deleted and the mysql container recreated.

We'll try to setup a meeting next week to answer your questions and get the application setup on your environment

Posts: 7
Joined: Fri Mar 21, 2014 7:14 pm

Fri Feb 11, 2022 11:01 pm Change Time Zone

Hello Jerry,

You are completely right.
While you were analyzing the issue, and after some time wandering around and reviewing things, I saw the text you mentioned and changed the value to the suggested value (db).
I did that in my Windows installation, and it didn't work. But, at this point, I don't trust that environment any more, as it could be a bit contaminated for so many trials and changes. (deep cleaning is on the way :-))

So, what I did was a fresh installation in Linux, fresh Docker installation, and fresh REAL-BI installation taking the "db" thing into consideration and also not changing almost anything else. (in my first attempts I had changed several ports)

And, voilá. It stopped throwing errors and a login page appeared!!!! Yeeeeey!!
Then I tried to log in and it told me "wrong credentials". :roll:
Then I remembered that this app was relying on the Auth-Service, and after a while, I figured out how to configure a user there. (I've never used it before)
And ... logged in !!!

Thank you !!!!! and also Thank you!!!
P.S. Unless you find some useful information in my previous attempt to install locally (not Docker), please disregard that post.
(15.31 KiB) Not downloaded yet
Posts: 25
Joined: Mon Nov 29, 2021 2:40 pm

Return to Programming

Who is online

Users browsing this forum: No registered users and 2 guests