Thu Aug 16, 2018 6:59 am
Login Register Lost Password? Contact Us


Cannot parse components from environment.xml

Post questions specific to installation or configuration for the HPCC Systems platform

Fri Oct 07, 2016 8:27 pm Change Time Zone

When I run configgen directly, this is what I have:

[root@hpcc004 HPCCSystems]# /opt/HPCCSystems/sbin/configgen -env /etc/HPCCSystems/environment.xml -listall2
EclAgentProcess,myeclagent,10.125.10.131,,/var/lib/HPCCSystems/myeclagent,
FTSlaveProcess,myftslave,10.125.10.131,,/var/lib/HPCCSystems/myftslave,
FTSlaveProcess,myftslave,10.125.10.132,,/var/lib/HPCCSystems/myftslave,
FTSlaveProcess,myftslave,10.125.10.133,,/var/lib/HPCCSystems/myftslave,
FTSlaveProcess,myftslave,10.125.10.134,,/var/lib/HPCCSystems/myftslave,
FTSlaveProcess,myftslave,10.125.10.135,,/var/lib/HPCCSystems/myftslave,
FTSlaveProcess,myftslave,10.125.10.136,,/var/lib/HPCCSystems/myftslave,
SashaServerProcess,mysasha,10.125.10.131,8877,/var/lib/HPCCSystems/mysasha,.
DaliServerProcess,mydali,10.125.10.131,7070,/var/lib/HPCCSystems/mydali,
DfuServerProcess,mydfuserver,10.125.10.131,,/var/lib/HPCCSystems/mydfuserver,
EclCCServerProcess,myeclccserver,10.125.10.131,,/var/lib/HPCCSystems/myeclccserver,
EspProcess,myesp,10.125.10.131,,/var/lib/HPCCSystems/myesp,
DafilesrvProcess,mydafilesrv,10.125.10.131,,/var/lib/HPCCSystems/mydafilesrv,
DafilesrvProcess,mydafilesrv,10.125.10.132,,/var/lib/HPCCSystems/mydafilesrv,
DafilesrvProcess,mydafilesrv,10.125.10.133,,/var/lib/HPCCSystems/mydafilesrv,
DafilesrvProcess,mydafilesrv,10.125.10.134,,/var/lib/HPCCSystems/mydafilesrv,
DafilesrvProcess,mydafilesrv,10.125.10.135,,/var/lib/HPCCSystems/mydafilesrv,
DafilesrvProcess,mydafilesrv,10.125.10.136,,/var/lib/HPCCSystems/mydafilesrv,
ThorMasterProcess,mythor,10.125.10.131,,/var/lib/HPCCSystems/mythor,
ThorSlaveProcess,mythor,10.125.10.133,,/var/lib/HPCCSystems/mythor,
ThorSlaveProcess,mythor,10.125.10.134,,/var/lib/HPCCSystems/mythor,
ThorSlaveProcess,mythor,10.125.10.135,,/var/lib/HPCCSystems/mythor,
ThorSlaveProcess,mythor,10.125.10.136,,/var/lib/HPCCSystems/mythor,
EclSchedulerProcess,myeclscheduler,10.125.10.131,,/var/lib/HPCCSystems/myeclscheduler,


But when I run service hpcc-init --componentlist, this is what I have:
[root@hpcc004 HPCCSystems]# service hpcc-init --componentlist
No components on this node as defined by /etc/HPCCSystems/environment.xml.

Any idea on what could cause this problem? At the same time, on a node with similar configuration, HPCCSystems was able to parse the .xml file correctly. All nodes have same hardware configuration, and all run LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Scientific Linux release 6.6 (Carbon)
Scientific Linux release 6.6 (Carbon)

Thanks,

Linh
linhbngo
 
Posts: 8
Joined: Tue Dec 17, 2013 10:37 pm

Fri Oct 07, 2016 9:00 pm Change Time Zone

Hi Linh,

The message "No components on this node as defined by /etc/HPCCSystems/environment.xml." means that the IP of the node that you are trying to run the HPCC cluster on is not listed in the environment.xml, though it may appear in the hardware section.

Verify that the IP of the node in question appears in environment.xml and that some HPCC component is actually assigned to run on that node. Also, if you run configgen with the the flag -ip <IP> it should list the components that are configured to run on the node with the given IP.

-Gleb
Gleb Aronsky
 
Posts: 22
Joined: Fri Feb 10, 2012 1:49 pm

Fri Oct 07, 2016 10:11 pm Change Time Zone

When I scan through the environment.xml file, it shows the node's IP address:
[root@hpcc004 ~]# more /etc/HPCCSystems/environment.xml | grep 134
name="node010134"
netAddress="10.125.10.134"/>
<Instance computer="node010134"
netAddress="10.125.10.134"
<Instance computer="node010134"
netAddress="10.125.10.134"
<ThorSlaveProcess computer="node010134" name="s2"/>
[root@hpcc004 ~]# more /etc/HPCCSystems/environment.xml | grep s2
name="s2"
name="s2"
<ThorSlaveProcess computer="node010134" name="s2"/>

and this is the ifconfig results:
[root@hpcc004 ~]# ifconfig
eth3 Link encap:Ethernet HWaddr 00:8C:FA:5A:FA:85
inet addr:10.125.10.134 Bcast:10.125.255.255 Mask:255.255.0.0
inet6 addr: 2620:103:a006:1:28c:faff:fe5a:fa85/64 Scope:Global
inet6 addr: fe80::28c:faff:fe5a:fa85/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
RX packets:39647692 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2689741060 (2.5 GiB) TX bytes:0 (0.0 b)

Ifconfig uses the ioctl access method to get the full address information, which limits hardware addresses to 8 bytes.
Because Infiniband address has 20 bytes, only the first 8 bytes are displayed correctly.
Ifconfig is obsolete! For replacement check ip.
ib0 Link encap:InfiniBand HWaddr A0:00:02:20:FE:80:00:00:00:00:00:00:00:00:00:00:00:00:00:00
inet addr:10.128.1.217 Bcast:10.128.31.255 Mask:255.255.224.0
inet6 addr: fe80::f652:1403:73:70f1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:65520 Metric:1
RX packets:69389 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1024
RX bytes:5027610 (4.7 MiB) TX bytes:456 (456.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1105 errors:0 dropped:0 overruns:0 frame:0
TX packets:1105 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:67087 (65.5 KiB) TX bytes:67087 (65.5 KiB)

but when I run configgen with the flag -ip, it does not show anything:
[root@hpcc004 ~]# /opt/HPCCSystems/sbin/configgen -env /etc/HPCCSystems/environment.xml -ip 10.125.10.134
[root@hpcc004 ~]#

I tested this against an xml file that was known to be working before, and the result is the same, configgen cannot derive the component type based on the ip address provided. I have also followed suggestions in another thread and change the interface flag in /etc/HPCCSystems/environment.conf from * to eth3, and still not able to identify the components. How does HPCCSystems acquire the ip address from the system to compare it against the ip address in environment.xml?
linhbngo
 
Posts: 8
Joined: Tue Dec 17, 2013 10:37 pm

Fri Oct 07, 2016 11:59 pm Change Time Zone

Hi Linh,

If this is a Thor slave node, then the master would start the slave process. What errors are you having running Thor jobs? Does the Thor log indicate any errors?
Gleb Aronsky
 
Posts: 22
Joined: Fri Feb 10, 2012 1:49 pm

Sat Oct 08, 2016 1:40 am Change Time Zone

This is my thormaster log:

00000001 2016-10-07 21:36:23.951 120417 120417 "Opened log file //10.125.10.131/var/log/HPCCSystems/mythor/thormaster.2016_10_07.log"
00000002 2016-10-07 21:36:23.951 120417 120417 "Build enterprise_5.4.8-1"
00000003 2016-10-07 21:36:23.951 120417 120417 "calling initClientProcess Port 20000"
00000004 2016-10-07 21:36:23.957 120417 120417 "Found file 'thorgroup', using to form thor group"
00000005 2016-10-07 21:36:23.957 120417 120417 "Checking cluster replicate nodes"
00000006 2016-10-07 21:36:23.960 120417 120417 "Cluster replicate nodes check completed in 2ms"
00000007 2016-10-07 21:36:23.961 120417 120417 "Global memory size = 193680 MB"
00000008 2016-10-07 21:36:23.961 120417 120417 "RoxieMemMgr: Setting memory limit to 203088199680 bytes (774720 pages)"
00000009 2016-10-07 21:36:23.961 120417 120417 "Transparent huge pages are not supported on this kernel. Requires kernel version > 2.6.38."
0000000A 2016-10-07 21:36:23.961 120417 120417 "Memory released to OS on each 256k 'page'"
0000000B 2016-10-07 21:36:23.961 120417 120417 "RoxieMemMgr: 774720 Pages successfully allocated for the pool - memsize=203088199680 base=0x7ed4fae00000 alignment=262144 bitmapSize=24210"
0000000C 2016-10-07 21:36:23.963 120417 120417 "Disk space: /var/lib/HPCCSystems/hpcc-data/thor = 38503 MB, /var/lib/HPCCSystems/hpcc-mirror/thor = 0 MB, /var/lib/HPCCSystems/mythor/temp = 3
8503 MB"
0000000D 2016-10-07 21:36:23.966 120417 120417 "Starting watchdog"
0000000E 2016-10-07 21:36:23.966 120417 120432 "Started watchdog"
0000000F 2016-10-07 21:36:23.966 120417 120417 "ThorMaster version 4.1, Started on 10.125.10.131:20000"
00000010 2016-10-07 21:36:23.966 120417 120417 "Thor name = mythor, queue = thor.thor, nodeGroup = mythor"
00000011 2016-10-07 21:36:23.966 120417 120417 "Waiting for 4 slaves to register"
00000012 2016-10-07 21:36:23.966 120417 120417 "Verifying connection to slave 4"
00000013 2016-10-07 21:36:33.966 120417 120417 "Still Waiting for minimum 4 slaves to connect"
00000014 2016-10-07 21:36:33.966 120417 120417 "waiting for slave 1 (10.125.10.133:20100)"
00000015 2016-10-07 21:36:33.967 120417 120417 "waiting for slave 2 (10.125.10.134:20100)"
00000016 2016-10-07 21:36:33.967 120417 120417 "waiting for slave 3 (10.125.10.135:20100)"
00000017 2016-10-07 21:36:33.967 120417 120417 "waiting for slave 4 (10.125.10.136:20100)"
00000018 2016-10-07 21:36:33.967 120417 120417 "Verifying connection to slave 3"
00000019 2016-10-07 21:36:43.966 120417 120417 "Still Waiting for minimum 4 slaves to connect"
0000001A 2016-10-07 21:36:43.966 120417 120417 "waiting for slave 1 (10.125.10.133:20100)"
0000001B 2016-10-07 21:36:43.966 120417 120417 "waiting for slave 2 (10.125.10.134:20100)"
0000001C 2016-10-07 21:36:43.966 120417 120417 "waiting for slave 3 (10.125.10.135:20100)"
0000001D 2016-10-07 21:36:43.966 120417 120417 "waiting for slave 4 (10.125.10.136:20100)"
0000001E 2016-10-07 21:36:43.966 120417 120417 "Verifying connection to slave 1"
0000001F 2016-10-07 21:36:55.216 120417 120417 "Still Waiting for minimum 4 slaves to connect"
00000020 2016-10-07 21:36:55.216 120417 120417 "waiting for slave 1 (10.125.10.133:20100)"
00000021 2016-10-07 21:36:55.216 120417 120417 "waiting for slave 2 (10.125.10.134:20100)"
00000022 2016-10-07 21:36:55.216 120417 120417 "waiting for slave 3 (10.125.10.135:20100)"
00000023 2016-10-07 21:36:55.216 120417 120417 "waiting for slave 4 (10.125.10.136:20100)"
00000024 2016-10-07 21:36:55.216 120417 120417 "Verifying connection to slave 2"
00000025 2016-10-07 21:37:12.091 120417 120417 "Still Waiting for minimum 4 slaves to connect"
00000026 2016-10-07 21:37:12.091 120417 120417 "waiting for slave 1 (10.125.10.133:20100)"
00000027 2016-10-07 21:37:12.091 120417 120417 "waiting for slave 2 (10.125.10.134:20100)"
00000028 2016-10-07 21:37:12.091 120417 120417 "waiting for slave 3 (10.125.10.135:20100)"
00000029 2016-10-07 21:37:12.091 120417 120417 "waiting for slave 4 (10.125.10.136:20100)"
0000002A 2016-10-07 21:37:12.091 120417 120417 "Verifying connection to slave 4"
0000002B 2016-10-07 21:37:37.403 120417 120417 "Still Waiting for minimum 4 slaves to connect"
0000002C 2016-10-07 21:37:37.403 120417 120417 "waiting for slave 1 (10.125.10.133:20100)"
0000002D 2016-10-07 21:37:37.403 120417 120417 "waiting for slave 2 (10.125.10.134:20100)"
0000002E 2016-10-07 21:37:37.403 120417 120417 "waiting for slave 3 (10.125.10.135:20100)"
0000002F 2016-10-07 21:37:37.403 120417 120417 "waiting for slave 4 (10.125.10.136:20100)"
00000030 2016-10-07 21:37:37.403 120417 120417 "Verifying connection to slave 3"
00000031 2016-10-07 21:38:15.371 120417 120417 "Still Waiting for minimum 4 slaves to connect"
00000032 2016-10-07 21:38:15.371 120417 120417 "waiting for slave 1 (10.125.10.133:20100)"
00000033 2016-10-07 21:38:15.371 120417 120417 "waiting for slave 2 (10.125.10.134:20100)"
00000034 2016-10-07 21:38:15.371 120417 120417 "waiting for slave 3 (10.125.10.135:20100)"
00000035 2016-10-07 21:38:15.371 120417 120417 "waiting for slave 4 (10.125.10.136:20100)"
00000036 2016-10-07 21:38:15.371 120417 120417 "Verifying connection to slave 2"

and then thormaster reported a TIMEOUT in starting mythor
linhbngo
 
Posts: 8
Joined: Tue Dec 17, 2013 10:37 pm

Mon Oct 10, 2016 8:06 pm Change Time Zone

But when I run service hpcc-init --componentlist, this is what I have:
[root@hpcc004 HPCCSystems]# service hpcc-init --componentlist
No components on this node as defined by /etc/HPCCSystems/environment.xml.


You're on node 134 according to your ifconfig output. 134 only has ftslave, dafilesrv, and a thorslave on it. None of those components are directly started by hpcc-init so --componentlist filters them out and you won't see them.

To start your thormaster what I would suggest is to go to 10.125.10.131 and run
Code: Select all
sudo service hpcc-init -c mythor restart
or from any node, run
Code: Select all
sudo /opt/HPCCSystems/sbin/hpcc-run.sh -c mythor restart
.

On 10.125.10.131 you should have output in your init_mythor log. Could you please post it? I'm worried that the slaves aren't being started remotely. After you start mythor, hop onto node 134 and check
Code: Select all
sudo ps aux | grep thorslave
.
mgardner
 
Posts: 13
Joined: Tue Jan 20, 2015 9:30 pm

Wed Oct 12, 2016 12:40 am Change Time Zone

When I run
Code: Select all
sudo service hppc-init -c mythor restart

the mythor message waits for a very long time, then it returns the following:
Code: Select all
[root@hpcc001 mythor]# sudo service hpcc-init -c mythor start
Starting mythor ...            [ TIMEOUT ]


The content of the log file on hpcc001 shows:
Code: Select all
[root@hpcc001 mythor]# more thormaster.2016_10_11.log
00000001 2016-10-11 20:31:22.614 118730 118730 "Opened log file //10.125.10.131/var/log/HPCCSystems/mythor/thormaster.2016_10_11.log"
00000002 2016-10-11 20:31:22.614 118730 118730 "Build enterprise_5.4.8-1"
00000003 2016-10-11 20:31:22.614 118730 118730 "calling initClientProcess Port 20000"
00000004 2016-10-11 20:31:22.620 118730 118730 "Found file 'thorgroup', using to form thor group"
00000005 2016-10-11 20:31:22.620 118730 118730 "Checking cluster replicate nodes"
00000006 2016-10-11 20:31:22.621 118730 118730 "Cluster replicate nodes check completed in 2ms"
00000007 2016-10-11 20:31:22.622 118730 118730 "Global memory size = 193680 MB"
00000008 2016-10-11 20:31:22.622 118730 118730 "RoxieMemMgr: Setting memory limit to 203088199680 bytes (774720 pages)"
00000009 2016-10-11 20:31:22.623 118730 118730 "Transparent huge pages are not supported on this kernel.  Requires kernel version > 2.6.38."
0000000A 2016-10-11 20:31:22.623 118730 118730 "Memory released to OS on each 256k 'page'"
0000000B 2016-10-11 20:31:22.623 118730 118730 "RoxieMemMgr: 774720 Pages successfully allocated for the pool - memsize=203088199680 base=0x7f39c2e00000 alignment=262144
bitmapSize=24210"
0000000C 2016-10-11 20:31:22.624 118730 118730 "Disk space: /var/lib/HPCCSystems/hpcc-data/thor = 38490 MB, /var/lib/HPCCSystems/hpcc-mirror/thor = 0 MB, /var/lib/HPCCSy
stems/mythor/temp = 38490 MB"
0000000D 2016-10-11 20:31:22.627 118730 118730 "Starting watchdog"
0000000E 2016-10-11 20:31:22.627 118730 118745 "Started watchdog"
0000000F 2016-10-11 20:31:22.627 118730 118730 "ThorMaster version 4.1, Started on 10.125.10.131:20000"
00000010 2016-10-11 20:31:22.627 118730 118730 "Thor name = mythor, queue = thor.thor, nodeGroup = mythor"
00000011 2016-10-11 20:31:22.628 118730 118730 "Waiting for 4 slaves to register"
00000012 2016-10-11 20:31:22.628 118730 118730 "Verifying connection to slave 1"
00000013 2016-10-11 20:31:32.627 118730 118730 "Still Waiting for minimum 4 slaves to connect"
00000014 2016-10-11 20:31:32.627 118730 118730 "waiting for slave 1 (10.125.10.133:20100)"
00000015 2016-10-11 20:31:32.627 118730 118730 "waiting for slave 2 (10.125.10.134:20100)"
00000016 2016-10-11 20:31:32.627 118730 118730 "waiting for slave 3 (10.125.10.135:20100)"
00000017 2016-10-11 20:31:32.627 118730 118730 "waiting for slave 4 (10.125.10.136:20100)"
00000018 2016-10-11 20:31:32.628 118730 118730 "Verifying connection to slave 2"
00000019 2016-10-11 20:31:42.627 118730 118730 "Still Waiting for minimum 4 slaves to connect"
0000001A 2016-10-11 20:31:42.627 118730 118730 "waiting for slave 1 (10.125.10.133:20100)"
0000001B 2016-10-11 20:31:42.627 118730 118730 "waiting for slave 2 (10.125.10.134:20100)"
0000001C 2016-10-11 20:31:42.627 118730 118730 "waiting for slave 3 (10.125.10.135:20100)"
0000001D 2016-10-11 20:31:42.627 118730 118730 "waiting for slave 4 (10.125.10.136:20100)"
0000001E 2016-10-11 20:31:42.627 118730 118730 "Verifying connection to slave 4"
0000001F 2016-10-11 20:31:53.877 118730 118730 "Still Waiting for minimum 4 slaves to connect"
00000020 2016-10-11 20:31:53.877 118730 118730 "waiting for slave 1 (10.125.10.133:20100)"
00000021 2016-10-11 20:31:53.877 118730 118730 "waiting for slave 2 (10.125.10.134:20100)"
00000022 2016-10-11 20:31:53.877 118730 118730 "waiting for slave 3 (10.125.10.135:20100)"
00000023 2016-10-11 20:31:53.877 118730 118730 "waiting for slave 4 (10.125.10.136:20100)"
00000024 2016-10-11 20:31:53.877 118730 118730 "Verifying connection to slave 3"
00000025 2016-10-11 20:32:10.752 118730 118730 "Still Waiting for minimum 4 slaves to connect"
00000026 2016-10-11 20:32:10.752 118730 118730 "waiting for slave 1 (10.125.10.133:20100)"
00000027 2016-10-11 20:32:10.752 118730 118730 "waiting for slave 2 (10.125.10.134:20100)"
00000028 2016-10-11 20:32:10.752 118730 118730 "waiting for slave 3 (10.125.10.135:20100)"
00000029 2016-10-11 20:32:10.752 118730 118730 "waiting for slave 4 (10.125.10.136:20100)"
0000002A 2016-10-11 20:32:10.752 118730 118730 "Verifying connection to slave 4"
0000002B 2016-10-11 20:32:36.064 118730 118730 "Still Waiting for minimum 4 slaves to connect"
0000002C 2016-10-11 20:32:36.064 118730 118730 "waiting for slave 1 (10.125.10.133:20100)"
0000002D 2016-10-11 20:32:36.064 118730 118730 "waiting for slave 2 (10.125.10.134:20100)"
0000002E 2016-10-11 20:32:36.064 118730 118730 "waiting for slave 3 (10.125.10.135:20100)"
0000002F 2016-10-11 20:32:36.064 118730 118730 "waiting for slave 4 (10.125.10.136:20100)"
00000030 2016-10-11 20:32:36.064 118730 118730 "Verifying connection to slave 3"
00000031 2016-10-11 20:33:14.032 118730 118730 "Still Waiting for minimum 4 slaves to connect"
00000032 2016-10-11 20:33:14.032 118730 118730 "waiting for slave 1 (10.125.10.133:20100)"
00000033 2016-10-11 20:33:14.032 118730 118730 "waiting for slave 2 (10.125.10.134:20100)"
00000034 2016-10-11 20:33:14.032 118730 118730 "waiting for slave 3 (10.125.10.135:20100)"
00000035 2016-10-11 20:33:14.032 118730 118730 "waiting for slave 4 (10.125.10.136:20100)"
00000036 2016-10-11 20:33:14.032 118730 118730 "Verifying connection to slave 3"
00000037 2016-10-11 20:34:10.984 118730 118730 "Still Waiting for minimum 4 slaves to connect"
00000038 2016-10-11 20:34:10.984 118730 118730 "waiting for slave 1 (10.125.10.133:20100)"
00000039 2016-10-11 20:34:10.984 118730 118730 "waiting for slave 2 (10.125.10.134:20100)"
0000003A 2016-10-11 20:34:10.984 118730 118730 "waiting for slave 3 (10.125.10.135:20100)"
0000003B 2016-10-11 20:34:10.984 118730 118730 "waiting for slave 4 (10.125.10.136:20100)"
0000003C 2016-10-11 20:34:10.984 118730 118730 "Verifying connection to slave 3"


Code: Select all
sudo ps aux | grep thorslave
on the slave nodes does not return anything, and the log on one of the slaves (with correct time stamp) shows the following:
Code: Select all
more init_thorslave_mythor_2016_10_11_20_31_20.log
2016-10-12T00:31:37: dependency dafilesrv started
2016-10-12T00:31:37: slave(10.125.10.133) init
2016-10-12T00:31:37: slave(s) starting
2016-10-12T00:31:37: rsync -e ssh -o LogLevel=QUIET -o StrictHostKeyChecking=no 10.125.10.131:/var/lib/HPCCSystems/mythor/thorgroup /var/lib/HPCCSystems/mythor/thorgroup
.slave
linhbngo
 
Posts: 8
Joined: Tue Dec 17, 2013 10:37 pm

Mon Oct 17, 2016 1:30 pm Change Time Zone

We need to make sure that the thorgroup.slave file is getting populated on the slave machine. I would suggest checking under /var/lib/HPCCSystems/mythor for thorgroup.slave. If it isn't there, try doing something like ...

Code: Select all
sudo -i
su hpcc
rsync -e "ssh -o LogLevel=QUIET -o StrictHostKeyChecking=no" 10.125.10.131:/var/lib/HPCCSystems/mythor/thorgroup /var/lib/HPCCSystems/mythor/thorgroup.slave
ls -lart /var/lib/HPCCSystems/mythor/
mgardner
 
Posts: 13
Joined: Tue Jan 20, 2015 9:30 pm

Tue Oct 25, 2016 1:08 pm Change Time Zone

Thank you for the suggestion, I finally got it to work. The error lies with the permission of mythor directory within /var/lib/HPCCSystems. In our settings, the hpcc account does not have administrative right, so I have to manually go in and set the permission for this directory itself. Once the correct permission is in place, rsync happens without a hitch and the cluster came up correctly.
linhbngo
 
Posts: 8
Joined: Tue Dec 17, 2013 10:37 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest