Mon Oct 18, 2021 11:52 pm
Login Register Lost Password? Contact Us


Compiler not configured

Post questions specific to installation or configuration for the HPCC Systems platform

Tue Jul 12, 2011 7:27 pm Change Time Zone

I downloaded the community edition, and I installed the VMWare player. I got ECL watch to load, and I was able to write the hello world, example and check its syntax in the query builder.

However the compiler is not configured and I can not run the code, as the code can not be compiled. I can not find the file: eclcc.exe anywhere on my box. Any ideas?
SkipSnow
 
Posts: 9
Joined: Fri Jun 17, 2011 5:25 pm

Tue Jul 12, 2011 8:12 pm Change Time Zone

Try the following (in the ECL IDE / querybuilder)
. go to preferences
. make sure the server IP is the IP of the eclwatch box (should be the IP of your VM instance)
. go to the compiler tab
. click the "reset" button
sort
 
Posts: 59
Joined: Wed May 11, 2011 1:54 pm

Tue Jul 12, 2011 9:00 pm Change Time Zone

Skip,

In addition are you using the latest ECL IDE that is available on the web site at -
http://hpccsystems.com/download/free-community-edition. Older versions of Query Builder will not work with the VM.

In addition, if it helps, please refer to the blog article http://arjunachala.blogspot.com/2011/07/ecl-part-i-loading-data.html.

Thanks

Arjuna
admin
Site Admin
Site Admin
 
Posts: 208
Joined: Thu Jan 27, 2011 10:58 am

Tue Jul 12, 2011 9:31 pm Change Time Zone

The current version is 6.0.0.6.682.1.

eclcc.exe can be found at c:\Program Files (x86)\HPCC Systems\HPCC\bin\ver_3_0.

I also let the installation process update my environment path
sort
 
Posts: 59
Joined: Wed May 11, 2011 1:54 pm

Tue Jul 12, 2011 9:44 pm Change Time Zone

Arjuna:

Thanks so much for your reply. I did a couple of things:
1: I ensured that the qBuilder configuration was as you specified, and as the manual specified.

2: I tried to push the 'reset' button on the compiler but nothing happened.

3: Though I got my querry builder through the resources link from ECL watch I downloaded and reinstalled the qBuilder from the web site as you suggested, It looks like it is the same version as the one I had installed (6.0.0.6.682.1).

Still I get the same error: Bye the way, I also have a warning in my 'Error window: Warning: SOAP -ENV: Client [no subcode] "An HTTP processing error occered" Detail, no detail. I believe there is another post on this issue.

Any further advise?

Thanks

Skip
SkipSnow
 
Posts: 9
Joined: Fri Jun 17, 2011 5:25 pm

Tue Jul 12, 2011 9:50 pm Change Time Zone

I have configured the compiler as per its path:
c:\Program Files (x86)\HPCC Systems\HPCC\bin\ver_3_0 and Now the system is up and running! Thanks so much. Skip.
SkipSnow
 
Posts: 9
Joined: Fri Jun 17, 2011 5:25 pm

Tue Jul 12, 2011 11:50 pm Change Time Zone

I am not sure how to allow the installation to affect the path. It seems to me that I have no choice about this, should I be restarting the computer after an install, and before running q Builder?
SkipSnow
 
Posts: 9
Joined: Fri Jun 17, 2011 5:25 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron