Thu Jul 07, 2022 7:11 am
Login Register Lost Password? Contact Us

Please Note: The HPCC Systems forums are moving to Stack Overflow. We invite you to post your questions on Stack Overflow utilizing the tag hpcc-ecl ( This legacy forum will be active and monitored during our transition to Stack Overflow but will become read only beginning September 1, 2022.

Issue with spray from first demo

Post questions specific to installation or configuration for the HPCC Systems platform

Wed Jan 23, 2019 2:43 pm Change Time Zone

Hi Ming,

With the 64x 7.0.6-1, the machine will not run at all. This is the session information from the machine from the last time I tried to run it:

Runtime attributes

Screen Resolution

720x400 @0,0
VM Uptime

0d 00:10:55
Clipboard Mode

Drag and Drop Mode


Nested Paging

Unrestricted Execution

Paravirtualization Interface

Guest Additions

Not Detected
Guest OS Type

Ubuntu (32-bit)
Remote Desktop Server Port

Not Available

Network statistics

Adapter 1

Data Transmitted

0 B
Data Received

0 B
Adapter 2

Data Transmitted

0 B
Data Received

0 B

Storage statistics

Controller: SATAController

SATA Port 0


Data Read

14732288 B
Data Written

1024 B

I tried the 32x just to see if it would run, and it does but gives me the same issue of no ip just like the 64x 7.0.2-1.

When I try ifconfig eth1 there is no ip.

The adapter2 has been setup as you suggest the entire time, I deleted the original one and made a new one. The new adapter ip is now with DHCP server enabled.

Posts: 7
Joined: Fri Jan 04, 2019 2:16 pm

Mon Jan 28, 2019 4:29 pm Change Time Zone

Update: I am still unable to run the 7.0.6-1 HPCC virtual image.

But I was able to fix the ip issue with the 7.0.2-1 image.

I went into the network settings in windows and found the host-only network that had been set up for the virtual box. it had DHCP server as not enabled even though in my virtual box settings I had it enabled. I had to then switch the adapter settings to configure manually. Once I applied that change it fixed the settings in my windows network settings. Not sure why it hadn't switched on its own, but now it gives me an ip that I was able to connect to ECL watch with and successfully sprayed the original text file.
Posts: 7
Joined: Fri Jan 04, 2019 2:16 pm

Wed Jan 30, 2019 3:50 pm Change Time Zone

On Windows Virtualbox doesn't switch to correct host-only adapter probably is due the host-only adapter names are different for Windows and Unix (Linux and Mac). Don't know why Virtualbox make this way. It is the case even before Oracle took over it. We build VM image on Linux.

As HPCC 7.0.6-1 and 7.0.2-1 VMs they shouldn't have any difference on Virtualbox settings. We tested several systems and they all work.

What is the problem you experienced? Still not get ip?
Posts: 32
Joined: Wed Dec 18, 2013 12:38 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest