Sun Aug 07, 2022 3:43 pm
Login Register Lost Password? Contact Us

Please Note: The HPCC Systems forums are moving to Stack Overflow. We invite you to post your questions on Stack Overflow utilizing the tag hpcc-ecl ( This legacy forum will be active and monitored during our transition to Stack Overflow but will become read only beginning September 1, 2022.

Cannot Connect to ECL Watch

Comments or questions specific to the features of ECL Watch

Fri Jul 01, 2016 3:54 pm Change Time Zone

I have just installed VirtualBox 5.0.20 r106931 and the image for the Ubuntu 64bit HPCC on my HP laptop running Windows10 (8GB ram and 1TB on disk). This has not been a straight-forward installation! After enabling virtualization on the BIOS and such, I have finally achieved a successful startup of the HPCC server. But when I enter to access ECL Watch from my browser, it cannot find it. Then I thought "VirtualBox shows the hostonly network ip addresses within a (low) and (hi) I tried a number of different addresses with the port :8010 tacked on...again "not found". Then I ran an ifconfig on the Ubuntu server itself: eth0 = eth1 = (the one the documentation points to) lo(localhost) = I've tried all of these with the port :8010 - NOTHING! I'm sure I'm missing some indiscriminate switch or something, but I've no idea where to look. Anyone have any suggestions?
John Meier
Posts: 20
Joined: Wed Jun 29, 2016 7:45 pm

Wed Jul 06, 2016 6:31 pm Change Time Zone

Sorry to hear you have been having problems. We are updating our documentation to alert users about the virtualization setting in the bios (another user has this issue last week). If there are other settings that are missing in our documentation please let us know.

Can you verify that you can ping from your desktop?
Can you run "sudo service hpcc-init status" to make sure everything is still running. When the VM starts we auto start everything- running hpcc-init status will let us know that everything is still ok. You should see all components - i.e.
myesp (pid 3030 ) is running ...
Posts: 59
Joined: Wed May 11, 2011 1:54 pm

Thu Jul 07, 2016 2:13 pm Change Time Zone

NET ip is only accessible from VM not from host system which is why is not reachable.

By default host-only card should be configured as second network card in VM unless something changed on the system or by user. In VM documentation it shows "VM VirtualBox Network Adapter 2".

To fix the problem there are two options:
1) Shutdown VM. Switch two network cards settings: make adapter 1 as NET and adapter 2 as host-only. Start VM
2) Change "Interface=eth1" to Interface=eth0" in /etc/environment.conf. Restart HPCC: sudo service hpcc-init restart.

1) is recommended method.
In either case access ECLWatch with host-only adapter ip (adapter 2).

Posts: 32
Joined: Wed Dec 18, 2013 12:38 pm

Thu Jul 07, 2016 3:18 pm Change Time Zone

Thank you for your responses. I had to turn virtualization on my laptop (Windows 10 has this option disabled by default). This was no easy feat since key access during boot-up to access the BIOS proved impossible! There is a bit of an arduous journey through the SYSTEMS panel, but I did enable it. I did flip the eth0 and eth1 values as suggested. At this point I sync'd the VM and the internal HPCC machine so everybody was speaking the same connections, rebooting the VirtualBox I don't know how many times...but success!!
I can now connect to ECL Watch and I ran a "Hello World" syntax check and execution and everything worked as it should.

I've worked on command-line Unix systems for years and even though Ubuntu hhas a GUI, I didn't use it. I did use the "ifconfig" and the "sudo service" commands, which were helpful in identifying that the system wasn't running but hung (which led to the BIOS check), as well as the IP addressing. The documentation I had showed the GUI, which threw me off :oops:

Again - thanks for the assist!
John Meier
Posts: 20
Joined: Wed Jun 29, 2016 7:45 pm

Return to ECL Watch

Who is online

Users browsing this forum: No registered users and 1 guest