Wed Aug 15, 2018 4:34 pm
Login Register Lost Password? Contact Us


HPCC Installiation question on AWS single node

Questions or comments related to Cloud Computing and the HPCC Systems Instant Cloud for AWS

Thu May 07, 2015 2:16 pm Change Time Zone

I got dependency error while installing HPCC Ubuntu versions in AWS Ubuntu AMI. Is there any document which outlines the most compatible AMI?

Steps I followed:
- started one micro ubuntu 14.x version instance
- downloaded hpcc ubuntu 14.x to my windows pc
- ftp the hpcc package to aws instance
- executed sudo dpkg -i <deb filename>

I am aware of the HPCC AWS offering. I would like to install HPCC on my own in AWS and don't want to research on dependencies and install them. Please help
balajisampath
 
Posts: 63
Joined: Mon Jul 22, 2013 6:29 pm

Thu May 07, 2015 6:48 pm Change Time Zone

Make sure you have the correct version of the HPCC Platform because the one you need depends on the operating system on your instance. (see http://hpccsystems.com/bb/viewtopic.php?f=14&t=1160).
tlhumphrey2
 
Posts: 250
Joined: Mon May 07, 2012 6:23 pm

Fri May 08, 2015 1:18 pm Change Time Zone

Thanks tlhumphrey2 ,

I wish dependencies packaged as part of HPCC.
balajisampath
 
Posts: 63
Joined: Mon Jul 22, 2013 6:29 pm

Fri May 08, 2015 6:55 pm Change Time Zone

Did you try installing with apt-get?

Jim
JimD
 
Posts: 132
Joined: Wed May 18, 2011 1:35 pm

Mon May 11, 2015 2:10 pm Change Time Zone

No Jim,

I didn't try. Will let you know soon.
balajisampath
 
Posts: 63
Joined: Mon Jul 22, 2013 6:29 pm

Fri Jul 31, 2015 8:52 pm Change Time Zone

I can't seem to get the dependencies resolved because hpcc depends on versions of libraries that are not available any more:

Code: Select all
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
hpccsystems-platform : Depends: libboost-regex1.40.0 but it is not installable
                        Depends: libicu42 but it is not installable
                        Depends: libarchive1 but it is not installable
                        Depends: zip
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@lab-hpcc-01:~# apt-get install zip
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
hpccsystems-platform : Depends: libboost-regex1.40.0 but it is not installable
                        Depends: libicu42 but it is not installable
                        Depends: libarchive1 but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@lab-hpcc-01:~# apt-get install libarchive1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libarchive1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libarchive-dev:i386 libarchive-dev

E: Package 'libarchive1' has no installation candidate
root@lab-hpcc-01:~# apt-get install libarchive-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
hpccsystems-platform : Depends: libboost-regex1.40.0 but it is not installable
                        Depends: libicu42 but it is not installable
                        Depends: libarchive1 but it is not installable
                        Depends: zip
libarchive-dev : Depends: libarchive13 (= 3.1.2-7ubuntu2.1) but 3.1.2-7ubuntu2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@lab-hpcc-01:~# apt-get install libarchive-dev
kovacsbv
 
Posts: 33
Joined: Fri Aug 05, 2011 12:53 pm


Return to Cloud

Who is online

Users browsing this forum: No registered users and 1 guest

cron