Mon Aug 15, 2022 9:56 am
Login Register Lost Password? Contact Us

Please Note: The HPCC Systems forums are moving to Stack Overflow. We invite you to post your questions on Stack Overflow utilizing the tag hpcc-ecl ( This legacy forum will be active and monitored during our transition to Stack Overflow but will become read only beginning September 1, 2022.

Roxie "Failed to get response from slave(s)" - SOLVED

Questions or comments related to Cloud Computing and the HPCC Systems Instant Cloud for AWS

Fri Jun 19, 2015 8:29 pm Change Time Zone

I recently ran across this issue while setting up a multi-Roxie system in AWS ... within a VPC I didn't control ... though one might have this issue in other envronments too.

After publishing a query, when I tried to execute the query ... after bit of a wait ... I received an error message as follows:

Reported by: Roxie
Message: Failed to get response from slave(s) for uid=0x00000003 activityId=8 (fetch part) pri=LOW queryHash=cd7737a0929de9b2 ch=8 seq=0 cont=0 server=XXX.XX.XX.159 retries=0003 in activity 8


At a high-level this message says that the Roxie nodes "can't talk to one another". Roxie nodes often talk to one another using UDP and optionally using "multicast". The defaulted setting in my environment.xml file was ... 'roxieMulticastEnabled="true"'.

In my environment, multicast requests were not being passed on my network ... so messages between Roxie nodes were never recieved. Once I configured Roxie to disable multicast (and ensured all necessary UDP networking was allowed between Roxie nodes) ... Roxie queries functioned normally.


    1) In your HPCC "environment.xml" file (usually /etc/HPCCSystems/environment.xml) set 'roxieMulticastEnabled="false"'.
    2) Ensure you allow the necessary UDP connections between your Roxie nodes.

Linux tools I found useful for helping to debug this problem:

    netstat -l (ports being listened on)
    lsof (open files and what they are attached to ... including TCP/UDP ports)

Additional Note:

Even after my change, I noticed that the actual Roxie process still opened the multicast address. I didn't experiment with configuration changes that would disable this.
Posts: 16
Joined: Thu Sep 13, 2012 7:52 pm

Sat Jun 20, 2015 7:00 pm Change Time Zone

It would be nice if some expert would tell us why roxieMulticastEnabled should be set to false. That seems counter-intuitive.

A related note: In the github repository: is a CloudFormation template and accompanying scripts, with documentation, that will configure and deploy a fast running HPCC System on AWS in just 2 steps. The scripts even set roxieMulticastEnabled to false if you indicate you want a roxie.
Posts: 260
Joined: Mon May 07, 2012 6:23 pm

Return to Cloud

Who is online

Users browsing this forum: No registered users and 1 guest