Thu Mar 22, 2018 6:06 am
Login Register Lost Password? Contact Us

What needs to be installed in order to build HPCC-Platform?

A place for developers to ask questions about contributing to the open source code base

Fri Apr 04, 2014 8:57 pm Change Time Zone

I recently built the HPCC-Platform on Linux. When I did the CMake, it kept bombing out saying that it needed this or that installed in order to continue. Some of these were very straight forward, such as bison and flex, and they were available right within my Linux distribution (Ubuntu 13). Others were not so easy and I had to consult with someone else who had previously built them. Some of the items to install had rather obscure names such as "lib...-dev". I was eventually able to build and install the whole thing.

I think it would be very helpful if the CMake script error message indicated the precise name of the package to install or at the very least that the documentation on the build included a list of every package that needs to be installed on my system in order for the build to work.
Posts: 28
Joined: Tue Jun 18, 2013 2:56 pm

Mon Mar 02, 2015 4:31 pm Change Time Zone

Posts: 19
Joined: Wed Dec 18, 2013 12:38 pm

Return to Contributors

Who is online

Users browsing this forum: No registered users and 1 guest