Mon Oct 26, 2020 7:26 am
Login Register Lost Password? Contact Us


Configuration issue on submit: "... is Unreachable"

Topics around the use of the VS Code & Eclipse plugins

Thu Sep 18, 2014 4:21 pm Change Time Zone

I have Eclipse (kepler) installed and installed the ECL plugin from hpccsystems.com (stable version per the instructions).

I set up the configuration: SSL (with self-signed cert), correct IP address and port, test of ECL Watch successful. I pointed clienttools to the install directory (I tried the base directory and bin both failed).

I tested the ECL Watch site and that shows correctly.

When I go to run I get a message that says "... is Unreachable."

Any thoughts on what I may have done wrong in the configuration?

thanks for the help
Windows 7 64-bit
Eclipse: Kepler service release 2
plugin: ECL_Language - 5.0.0.101
jh
 
Posts: 3
Joined: Thu Sep 18, 2014 4:09 pm

Thu Sep 18, 2014 9:10 pm Change Time Zone

When you say tested ECL Watch Site - was that within the run Configuration page?

For the ECLCC Compiler tab on the run configurations page, can you leave the "Override Defaults" off and try again.
gsmith
 
Posts: 285
Joined: Thu May 12, 2011 9:40 am

Thu Sep 18, 2014 9:20 pm Change Time Zone

gsmith,

Yes the test was within the configuration page. I also copied that URL and opened the site in a browser just to be 100% positive. :-)

I tried using the default location for the ECLCC Compiler and that didn't work with the SSL target/website but did work with our non-SSL site.

So improvement. :-) Thanks!

So now the question is how to get the plugin to work with a self-signed cert? (The assumption here being the self-signed cert is the issue at this point.)
jh
 
Posts: 3
Joined: Thu Sep 18, 2014 4:09 pm

Fri Sep 19, 2014 1:40 pm Change Time Zone

I think self sign certs and Java is a general "issue", in so far as you have to manually add it to the keystore.

Quick google led me here: http://stackoverflow.com/questions/6840 ... to-eclipse

Can you post back if this works?
gsmith
 
Posts: 285
Joined: Thu May 12, 2011 9:40 am

Fri Sep 19, 2014 4:12 pm Change Time Zone

gsmith,
No that didn't work...

I was able to add it fine the keystore. But I still get the error.
jh
 
Posts: 3
Joined: Thu Sep 18, 2014 4:09 pm

Fri Sep 19, 2014 4:14 pm Change Time Zone

Lemme check with some of the folks here, as we hit this exact issue...
gsmith
 
Posts: 285
Joined: Thu May 12, 2011 9:40 am

Fri Sep 19, 2014 5:36 pm Change Time Zone

If you have multiple versions of java installed make sure you are installing the certificate into the correct keystore.

The first time I did the keystore I installed the cert into a different version of java than my application was using.
This may help though it is probably the same as the stackoverflow link above.
http://docs.oracle.com/javase/tutorial/ ... step2.html

Also there is a setting in Axis that allows for invalid certs, though I'm not sure if you could add this to your configuration.
AxisProperties.setProperty("axis.socketSecureFactory",
"org.apache.axis.components.net.SunFakeTrustSocketFactory");
joe.chambers
 
Posts: 21
Joined: Wed Apr 27, 2011 1:07 pm


Return to VS Code and Eclipse IDE

Who is online

Users browsing this forum: No registered users and 1 guest