Mon Oct 18, 2021 11:25 pm
Login Register Lost Password? Contact Us

KEL runtime error

Comments and questions related to the Enterprise Control Language

Thu Jun 02, 2016 4:50 pm Change Time Zone

A simple KEL file generates the following when executed on Thor cluster.
System error: 0: Graph[143], SLAVE #1 []: Graph[143], indexwrite[147]: Key row too large to fit within a key node (uncompressed size=40457, variable=true, pos=0),

The KEL file is;
Code: Select all
Play := ENTITY(FLAT(UID=playid, seq, playNum,
      type, possession, time, quarter,
      down, yardnet, yardline, scoring, ptsHome, ptsAway,
      toHome, toAway, description));
Play := ENTITY(FLAT(UID=playid, type, time);

USE NFL.plays(FLAT, Play);

/* every way that I tried to execute the query below returns error:
* Key row too large to fit within a key node (uncompressed size=40457, variable=true, pos=0)

//QUERY: A <= Play;
//QUERY: B <= Play(type='KICKOFF');
QUERY: C <= Play(time=15);

Regarding the code that is commented out. Because of the "key row too large" in the error, I tried using an entity with fewer fields. Same error. I tried several query versions and all failed with the above error.

Last note: I am able to run other KEL queries. In fact, I stripped out 3 other entiries and a few associations from the original KEL file before posting it above.

The ECL record corresponding to NFL.Plays is
Code: Select all
export PlayLayout := Record
   unsigned8 pid;
   unsigned1 seq;
   unsigned4 gameid;
   unsigned2 playid;
   string playtype;
   string1 possesion;
   unsigned2 time;
   unsigned1 quarter;
   unsigned1 down;
   unsigned1 yardline;
   boolean scoringplay;
   unsigned1 awayscore;
   unsigned1 homescore;
   unsigned1 awaytimeouts;
   unsigned1 hometimeouts;
   string description;
Posts: 28
Joined: Tue Feb 10, 2015 8:12 pm

Return to ECL

Who is online

Users browsing this forum: Bing [Bot] and 1 guest