Sun Nov 28, 2021 4:57 am
Login Register Lost Password? Contact Us


You do not have permission to directly access datafiles

Comments and questions related to the Enterprise Control Language

Fri Nov 09, 2018 1:05 am Change Time Zone

Getting this error when attempting to read a logical file:
"You do not have permission to directly access datafiles"
This is HPCC 6.4.10-1.

Is there a configuration change or #OPTION or some other way to get around this?
Thanks.
jwilt
 
Posts: 56
Joined: Wed Feb 27, 2013 7:46 pm

Fri Nov 09, 2018 1:30 pm Change Time Zone

Jim,

Sounds to me like LDAP permissions.

HTH,

Richard
rtaylor
Community Advisory Board Member
Community Advisory Board Member
 
Posts: 1604
Joined: Wed Oct 26, 2011 7:40 pm

Fri Nov 09, 2018 3:36 pm Change Time Zone

Yes, of course that’s the obvious first thought. And it may be.
I’m missing in the HPCC documentation exactly where it explains how to set the proper permissions, what OUs are involved, etc.
This very error message is verbatim found in the source code (easily found by a google search, not by a GitHub search). Apparently added in v6. Hard to track in the source code where it’s set. Seems like it may be an eclcc option, something about “datafile”.
I haven’t yet found reference to this elsewhere.
jwilt
 
Posts: 56
Joined: Wed Feb 27, 2013 7:46 pm

Wed Nov 14, 2018 5:29 am Change Time Zone

jwilt
 
Posts: 56
Joined: Wed Feb 27, 2013 7:46 pm


Return to ECL

Who is online

Users browsing this forum: Google [Bot] and 1 guest