Mon Oct 25, 2021 1:50 am
Login Register Lost Password? Contact Us


graph control stopped working

Topics specific to the use of the ECL IDE

Wed Jan 11, 2012 2:19 pm Change Time Zone

Hello,
My graph visualizer was working fine and suddenly stopped working. I've tried uninstalling and re-installing but it's still not working.

It actually loads for a split second and I can even see the graph but then my browser reports:
"The HPCCSystemsGraphViewControl plugin has crashed."

Followed by a dialog box:
"Graph Control Needs to be installed to visualize activity graphs."

I've tried uninstalling and reinstalling, then I tried a repair, then I tried installing a previous version. Any ideas for how to get it back?

Thanks!
aintnomyth
 
Posts: 86
Joined: Wed Jul 13, 2011 7:40 pm

Wed Jan 11, 2012 2:26 pm Change Time Zone

This sometimes happen if you install an older IDE (or QueryBuilder). In general it can be resolved by:

1. Close all instances of IDE/QB
2. Open newest IDE
3. Goto Prefs/Other and click the "Install X.Y.Z" option (just noticed that they are missing a title/group "Graph Control").

Gordon.
gsmith
 
Posts: 290
Joined: Thu May 12, 2011 9:40 am

Wed Jan 11, 2012 2:58 pm Change Time Zone

Thanks for the reply. I uninstalled the current graph control from control panel, closed my browsers and IDE, but now the "Install Version" is grayed out so I can't click it.
aintnomyth
 
Posts: 86
Joined: Wed Jul 13, 2011 7:40 pm

Wed Jan 11, 2012 3:08 pm Change Time Zone

On my machine the "manual" way to do the same is (from a command prompt with admin rights):

cd "C:\Program Files (x86)\HPCC Systems\HPCC\Graph Control"
regsvr32 npHPCCSystemsGraphViewControl.dll

Gordon.

PS Again, the above folder should be the latest IDE on your machine.
gsmith
 
Posts: 290
Joined: Thu May 12, 2011 9:40 am

Wed Jan 11, 2012 4:03 pm Change Time Zone

Thanks again, I tried registering from the command prompt (launching cmd in run-as-administrator mode).

The regsvr32 command works when I have the prior graph control installed (v 5.x) but the graphs still crash after they briefly display.

The regsvr32 command fails when I have the current graph control installed (v 6.x), I get a windows popup that says:
"specified module could not be found"


I'm on windows 7 64 bit if it matters, but the graphs were displaying wonderfully until they suddenly started crashing. :(
aintnomyth
 
Posts: 86
Joined: Wed Jul 13, 2011 7:40 pm

Wed Jan 11, 2012 4:26 pm Change Time Zone

You want the v6 one.

Can you double check the content of the folder in question to see if the DLLs are actually there?
expat.dll
graphdb.dll
graphlayout.dll
graphrender.dll
npHPCCSystemsGraphViewControl.dll

Gordon.
gsmith
 
Posts: 290
Joined: Thu May 12, 2011 9:40 am

Wed Jan 11, 2012 4:55 pm Change Time Zone

expat.dll
graphdb.dll
graphlayout.dll
graphrender.dll
npHPCCSystemsGraphViewControl.dll

With version 5 installed I have all of the files listed. With version 6 I only have npHPCCSystemsGraphViewControl.dll.

I think version 6 isn't finishing the install process. I double click the .msi and a progress bar appears but nothing after that. I didn't notice that until I installed 5 and 6 back to back.
aintnomyth
 
Posts: 86
Joined: Wed Jul 13, 2011 7:40 pm

Wed Jan 11, 2012 5:32 pm Change Time Zone

I would guess version 6 has been partially uninstalled? Can you reinstall it?
gsmith
 
Posts: 290
Joined: Thu May 12, 2011 9:40 am

Wed Jan 23, 2013 5:01 pm Change Time Zone

I also cannot see WU graphs now I've upgraded to 3.10 IDE + client tools.
(I'm using Windows 7 64 bit)

All I have installed is:
Code: Select all
Directory of C:\Program Files (x86)\HPCC Systems\HPCC

22/01/2013  11:45    <DIR>          .
22/01/2013  11:45    <DIR>          ..
16/04/2012  13:30    <DIR>          bin
22/01/2013  11:45    <DIR>          ECL IDE
22/01/2013  11:45    <DIR>          Graph Control x64
22/01/2013  11:45    <DIR>          ver_3_6

And under 'Graph Control x64'
Code: Select all
Directory of C:\Program Files (x86)\HPCC Systems\HPCC\Graph Control x64

22/01/2013  11:45    <DIR>          .
22/01/2013  11:45    <DIR>          ..
19/11/2012  12:01         4,105,728 npHPCCSystemsGraphViewControl.dll

I've attempted using the regsvr32 mentioned above to no avail. (I expected not)

being a work machine I'm constrained in the browsers I can use, I have IE8 and Firefox ?

Any help would be greatly appreciated.

Yours

Allan
Allan
 
Posts: 442
Joined: Sat Oct 01, 2011 7:26 pm

Wed Jan 23, 2013 5:13 pm Change Time Zone

Sorted!

Found the 32-bit version of Graph control dll on this HPCC site, installed, then run that regsvr32 and Graph now works at 3.10 (also on firefox)

Yours

Allan
Allan
 
Posts: 442
Joined: Sat Oct 01, 2011 7:26 pm


Return to ECL IDE

Who is online

Users browsing this forum: No registered users and 1 guest

cron