Thu Aug 18, 2022 10:10 am
Login Register Lost Password? Contact Us

Please Note: The HPCC Systems forums are moving to Stack Overflow. We invite you to post your questions on Stack Overflow utilizing the tag hpcc-ecl (https://stackoverflow.com/search?tab=newest&q=hpcc-ecl). This legacy forum will be active and monitored during our transition to Stack Overflow but will become read only beginning September 1, 2022.



ECL IDE fails to run on Window

Topics specific to the use of the ECL IDE

Wed May 04, 2016 1:27 pm Change Time Zone

Tried to install ECLIDE on Window 8.1 Enterprise 64-bit.

1. Downloaded hpccsystems-eclide-community_5.6.2-1Windows-i386.exe
2. Installed it.
3. Launched ECL IDE got error because api-ms-win-crt-runtime-l1-1-0.dll not found. See attached figure.

Screen Shot 2016-05-03 at 3.49.47 PM.png
ECLIDE.exe System Error
(153.73 KiB) Downloaded 1400 times


Solution:

Install Microsoft Visual C++ (help found at this link: http://forums.autodesk.com/t5/installat ... 17/td-p/62
31310)

4. Re-launched ECL IDE: now get eclcc.exe error.

Screen Shot 2016-05-03 at 4.06.01 PM.png
Compiler mismatch
(235.62 KiB) Downloaded 1400 times


5. The cluster has a different version. From shell on cluster:

$ eclcc --version
5.4.6 community_5.4.6-1

At this point I started all over with a fresh Windows instance.

6. Installed HPCC Client Tools for Windows version 5.4.6-1 (the version that matches the cluster).
7. Installed ECL IDE 5.6.2-1 (because I could not find version 5.4.6-1).
8. Installed dll as discussed in #3 above.
9. Launched ECL IDE
10. In "Preferences > Compiler" overrode compiler to use 5.4.6 instead of 5.6.2.
11. Connected to cluster.
12. Alas, eclcc.exe crashes again. It actually crashes many times. At least I have to close the "eclcc.exe has stopped working" popup about 9 times. No window pops up with an error as in #4 above. However, after closing the "not working" popup 5 times the following error appears in the ECL IDE error log window.

WARNING: SP Exception - CSoapResponseBinding: ... Client version build_3_08 (server community_5.4.6-1) is out of date.

I am able to use the cluster from ECL IDE running on my Mac in Wine. That version is 5.4.2-1 as is the compiler.

13. Therefore, I download the ECL IDE & Client Tools version 5.4.2-1, installed it on a fresh windows instance. Again, eclcc.exe stops working--complains about a compiler mismatch.

I am out of ideas. We will consider upgrading the cluster to 5.6.2-1. But that is just a workaround.

Summary:
  • Must load dll to run IDE (5.6.2)
  • Server(5.4.6) + IDE (5.6.2) + CTools (5.6.2) -> compiler mismatch error in popup
  • Server(5.4.6) + IDE (5.6.2) + CTools (5.4.2) -> compiler out of date in IDE error log
  • Server(5.4.6) + IDE (5.4.2) + CTools (5.4.2) on Mac in Wine -> Works
  • Server(5.4.6) + IDE (5.4.2) + CTools (5.4.2) -> compiler mistmatch error in popup
Last edited by vin on Wed May 04, 2016 6:47 pm, edited 1 time in total.
vin
 
Posts: 28
Joined: Tue Feb 10, 2015 8:12 pm

Wed May 04, 2016 2:11 pm Change Time Zone

rtaylor
Community Advisory Board Member
Community Advisory Board Member
 
Posts: 1619
Joined: Wed Oct 26, 2011 7:40 pm

Mon May 09, 2016 5:07 pm Change Time Zone

Have you tried to apply the update for Universal C Runtime in Windows: https://support.microsoft.com/en-us/kb/2999226?

It is a work-around. We will try to fix it in our next HPCC Clienttools relesae.
ming
 
Posts: 32
Joined: Wed Dec 18, 2013 12:38 pm

Fri May 20, 2016 12:56 am Change Time Zone

Update: ECLIDE is working with KEL.

I do not know what change made it work but the configuration is:

1. ECLIDE 6.0.0
2. KEL 0.7 (5.6.2)
3. Java JDK 8u92

Thanks,
+vince
vin
 
Posts: 28
Joined: Tue Feb 10, 2015 8:12 pm

Fri May 20, 2016 12:21 pm Change Time Zone

Glad to hear it works. ECLIDE 6.0.0 includes Clienttools build with improved required runtime libraries package.
ming
 
Posts: 32
Joined: Wed Dec 18, 2013 12:38 pm


Return to ECL IDE

Who is online

Users browsing this forum: No registered users and 1 guest