Mon Nov 29, 2021 9:18 pm
Login Register Lost Password? Contact Us


Compatibility

Topics specific to the use of the ECL IDE

Mon Apr 30, 2012 7:18 pm Change Time Zone

What kind of compatibility can we expect in regards to mixing versions of the IDE and the server? None? Will later versions of the IDE work with older versions of the server?

I'm specifically wondering about 3.6.2 versus 3.6.0, but the general question sounds better.

Thanks!

Dan
DSC
Community Advisory Board Member
Community Advisory Board Member
 
Posts: 568
Joined: Tue Oct 18, 2011 4:45 pm

Mon Apr 30, 2012 8:08 pm Change Time Zone

In general the latest version of the IDE will work with _all_ older versions (and will have a fair chance of working with newer versions).

BUT - There is a tighter coupling between the eclcc compiler and the server version.

You may have noticed that 3.6.x IDE includes two sets of "Client Tools" 3.6 + 3.0. The user gets to choose which Client Tools to use on a per-configuration basis (at the moment they pick 3.0 for all server version <= 3.4.x and 3.6 for all versions > 3.6.0, thus allowing the one IDE to target any server version released (to-date).

Note: If the user submits a query with the wrong version of eclcc they will receive a warning.

For the "point" version change (versioning: major.minor.point) there would never be any intentional breaking change from the client eclcc point of view. IOW the latest 3.6.X IDE (and client tools) should always be the "best" one to use for ALL 3.6.Y servers.

From 3.8 onwards we plan on packaging the client tools as separate downloadable and installable entities (which will then get bundled with the IDE or Eclipse etc.)

HTH, Gordon.
gsmith
 
Posts: 290
Joined: Thu May 12, 2011 9:40 am

Mon Apr 30, 2012 8:48 pm Change Time Zone

Excellent. Thanks, Gordon!
DSC
Community Advisory Board Member
Community Advisory Board Member
 
Posts: 568
Joined: Tue Oct 18, 2011 4:45 pm


Return to ECL IDE

Who is online

Users browsing this forum: No registered users and 1 guest