Tue Aug 21, 2018 2:41 am
Login Register Lost Password? Contact Us


Background save still in progress

Topics specific to the use of the ECL IDE

Mon Jun 19, 2017 5:09 pm Change Time Zone

I am trying to copy the results of a WU to Excel, but I keep getting a message "Background save still in progress". There are only ~400 records, this is not a huge volume. I was using IDE version 6.0 , got this error a bunch of times (but not for every result), downloaded 6.2 and still got the error. What can I do to avoid this productivity killing demon that has started to haunt my days?
Attachments
Copy.png
Copy.png (15.64 KiB) Viewed 635 times
janet.anderson
 
Posts: 29
Joined: Wed Jul 17, 2013 5:31 pm

Mon Jun 19, 2017 5:40 pm Change Time Zone

Are you downloading the CSV of the result?
DownloadCSV.jpg
DownloadCSV.jpg (103.86 KiB) Viewed 628 times

1. Select the ECL Watch view of the workunit
2. Select the Outputs tab
3. Open the result you want by clicking on the hyperlink
4. Press the CSV button
5. The browser instance will prompt you (depending on your browser settings)

HTH,

Jim
JimD
 
Posts: 132
Joined: Wed May 18, 2011 1:35 pm

Mon Jun 19, 2017 5:56 pm Change Time Zone

Thanks for the response. I have found viewing results in ECL Watch to be a) an extra step to get to, b) fairly slow to refresh compared to the IDE (when the IDE works). So although I do appreciate having an alternative approach, is there something I can do to regain the functionality in the results tab that I used to have consistently?
janet.anderson
 
Posts: 29
Joined: Wed Jul 17, 2013 5:31 pm

Mon Jun 19, 2017 7:48 pm Change Time Zone

I was talking about the ECL Watch view inside the IDE. Unfortunately, the image I included did not display so you could not see what I meant.

In the IDE, under the builder window, when you open a successful workunit, you get at least 2 tabs, the first one on the left is an ECL Watch view.

How are you trying to download your results now?

I was able to save using the method I previously mentioned and I also saved by rt-clicking on a result display in the IDE and selecting Save As. The Save As method prompts me that "Not all results have been downloaded..." but the results did save to CSV in a moment or two. My test with 1 million records took about a minute and 1,000 took about 10 or 15 seconds (only a guestimate).
JimD
 
Posts: 132
Joined: Wed May 18, 2011 1:35 pm

Mon Jun 19, 2017 7:51 pm Change Time Zone

Thanks, Jim. I will try the method you suggested.
janet.anderson
 
Posts: 29
Joined: Wed Jul 17, 2013 5:31 pm

Mon Jun 19, 2017 7:54 pm Change Time Zone

The earlier image is now displaying.
JimD
 
Posts: 132
Joined: Wed May 18, 2011 1:35 pm

Mon Jun 19, 2017 8:00 pm Change Time Zone

Since I can NOW see the images, I think you were trying select All, then rt-click>Copy which works with a small result. But, for a result that is returned in pages, you would never know when the results have completed downloading to the clipboard.

In your scenario, I would use the rt-click > Save As method.
JimD
 
Posts: 132
Joined: Wed May 18, 2011 1:35 pm


Return to ECL IDE

Who is online

Users browsing this forum: No registered users and 1 guest

cron