Mon Nov 29, 2021 9:38 pm
Login Register Lost Password? Contact Us


Sudden Compile/Link failure

Topics specific to the use of the ECL IDE

Tue Jul 17, 2012 10:22 pm Change Time Zone

I was able to use the IDE using the VM just fine until today when I started getting this error:

The code I'm executing at this point is just 'output(5);' in a builder.

Error: Compile/Link failed for C:\HPCC\ECLSource\ECL\wu\L20120717-175737 (see '\\192.168.1.66\c$\HPCC\ECLSource\ECL\wu\eclcc.log' for details) (0, 0), 3000, C:\HPCC\ECLSource\ECL\wu\L20120717-175737
I've included eclcc.log as an appendix to this message, also an excerpt from what I think are the pertinent parts of my configuration file, which have not changed since yesterday when things were peachy.

The eclcc.bin file is in the expected place, and 'check' executes fine.
Calling eclcc from a shell seems to work as well.

Restarting the IDE, VM and my machine do not have an effect.

Thanks for any help.

***APPENDIX *****
----eclcc.log ----------
00000000 2012-07-17 17:57:37 3452 5376 Loading plugin C:\Program Files\HPCC Systems\HPCC\bin\ver_3_6\plugins\auditlib.dll[lib_auditlib] version = AUDITLIB 1.0.1
00000001 2012-07-17 17:57:37 3452 5376 Loading plugin C:\Program Files\HPCC Systems\HPCC\bin\ver_3_6\plugins\dmetaphone.dll[lib_metaphone] version = DMETAPHONE 1.1.05
00000002 2012-07-17 17:57:37 3452 5376 Loading plugin C:\Program Files\HPCC Systems\HPCC\bin\ver_3_6\plugins\fileservices.dll[lib_fileservices] version = FILESERVICES 2.1.3
00000003 2012-07-17 17:57:37 3452 5376 Loading plugin C:\Program Files\HPCC Systems\HPCC\bin\ver_3_6\plugins\logging.dll[lib_logging] version = LOGGING 1.0.1
00000004 2012-07-17 17:57:37 3452 5376 Loading plugin C:\Program Files\HPCC Systems\HPCC\bin\ver_3_6\plugins\parselib.dll[lib_parselib] version = PARSELIB 1.0.1
00000005 2012-07-17 17:57:37 3452 5376 Loading plugin C:\Program Files\HPCC Systems\HPCC\bin\ver_3_6\plugins\stringlib.dll[lib_stringlib] version = STRINGLIB 1.1.14
00000006 2012-07-17 17:57:37 3452 5376 Loading plugin C:\Program Files\HPCC Systems\HPCC\bin\ver_3_6\plugins\unicodelib.dll[lib_unicodelib] version = UNICODELIB 1.1.05
00000007 2012-07-17 17:57:37 3452 5376 Loading plugin C:\Program Files\HPCC Systems\HPCC\bin\ver_3_6\plugins\workunitservices.dll[lib_WORKUNITSERVICES] version = WORKUNITSERVICES 1.0.1
00000008 2012-07-17 17:57:38 3452 5376 Adding library: eclrtl
00000009 2012-07-17 17:57:38 3452 5376 Adding library: C:\HPCC\ECLSource\ECL\wu\L20120717-175737.res
0000000A 2012-07-17 17:57:38 3452 5376 Compiling C:\HPCC\ECLSource\ECL\wu\L20120717-175737
0000000B 2012-07-17 17:57:39 3452 5376 Failed to compile C:\HPCC\ECLSource\ECL\wu\L20120717-175737
0000000C 2012-07-17 17:57:39 3452 5376 Fatal Error: Unable to locate C++ compiler/linker
0000000D 2012-07-17 17:57:39 3452 5376
---------- compiler output --------------
'"vsvars32"' is not recognized as an internal or external command,

operable program or batch file.

'cl.exe' is not recognized as an internal or external command,

operable program or batch file.

--end eclcc.log -------------

-- config file ----------------
Config:
[Compiler]
Location=C:\Program Files\HPCC Systems\HPCC\bin\ver_3_6\eclcc.exe
EclWorkingFolder=C:\HPCC\ECLSource\ECL\wu
EclFolder00=C:\HPCC\ECLSource\ECL\My Files
EclFolder01=C:\HPCC\ECLSource\ECL\Samples
...
Version=6.6.2.1001.682.1
...
--- end config file -----------
eric.scott
 
Posts: 16
Joined: Mon Apr 09, 2012 10:05 pm

Tue Jul 17, 2012 11:03 pm Change Time Zone

I think I found the problem. I must inadvertently have reset the cluster to 'Local'. When I changed it to 'thor' everything worked fine.

Sorry for the confusion.
eric.scott
 
Posts: 16
Joined: Mon Apr 09, 2012 10:05 pm


Return to ECL IDE

Who is online

Users browsing this forum: No registered users and 1 guest