Thu Aug 16, 2018 6:54 am
Login Register Lost Password? Contact Us


ECL IDE crashing when connecting to git repository

Topics specific to the use of the ECL IDE

Thu Aug 31, 2017 1:43 pm Change Time Zone

Hi there,

I am attempting to connect to a Git repository through ECL IDE and the IDE keeps crashing. The exception reason is "ECLIDE.exe caused ACCESS_VIOLATION at 0023:006D0120". I have version 6.4.0.101 installed and am using the following compiler: C:\Program Files (x86)\HPCCSystems\6.4.0\clienttools\bin\eclcc.exe. My ECL Folder is set to the location of my git repository.

Sometimes the repository loads and it crashes when I click on it, and other times it crashes before the repository even loads. I have the crash report if needed, but it is too big to attach here.

Any assistance would be greatly appreciated.

Thanks in advance,
Beth
elouche
 
Posts: 2
Joined: Tue May 05, 2015 6:51 pm

Mon Sep 11, 2017 3:58 pm Change Time Zone

Thanks for the report. While there is one known (crashing) issue with that release, it is different to what your describing.

For sanity can you check if the previous 6.2.x release works or if it is also failing.
(Its ok to have both installed, as the IDE will auto select the correct Client Tools versions for the server your targeting).

Also does your git folder contain:
* Many files?
* Non ECL files?

Finally if you get an option to forward a crash report, please do as it often contains useful information.

Thx.
gsmith
 
Posts: 275
Joined: Thu May 12, 2011 9:40 am


Return to ECL IDE

Who is online

Users browsing this forum: No registered users and 1 guest