Wed Jul 08, 2020 12:05 pm
Login Register Lost Password? Contact Us


Invalid Workunit

Topics specific to the use of the ECL IDE

Sun Sep 15, 2019 12:15 pm Change Time Zone

I'm trying to follow the tutorial and run the Hello World program but keep getting this Invalid Workunit error message:

WsWorkunits.WUInfo
2019-09-15 12:14:27 GMT: WUInfo: Invalid Workunit ID: L20190915-081424

I could not find someone with a similar problem and would appreciate any help I can get.
Attachments
hpccerror.png
(137.6 KiB) Not downloaded yet
swampsoda
 
Posts: 2
Joined: Sun Sep 15, 2019 12:06 pm

Mon Sep 16, 2019 1:13 pm Change Time Zone

swampsoda,

Because your WUID begins with "L" that tells me you're compiling "Local" -- try selecting "Thor" from the target droplist and see if that corrects the issue.

HTH,

Richard
rtaylor
Community Advisory Board Member
Community Advisory Board Member
 
Posts: 1545
Joined: Wed Oct 26, 2011 7:40 pm

Mon Sep 16, 2019 3:01 pm Change Time Zone

Swampsoda,

In addition. if your submitted ECL has a syntax error, your Workunit ID may begin with an L (indicating Local) because that is where the error occurred. In other words, it failed to syntax check locally before ever reaching Thor.

Do any syntax errors display in the IDE?

HTH,

Jim
JimD
 
Posts: 154
Joined: Wed May 18, 2011 1:35 pm

Tue Sep 17, 2019 2:10 am Change Time Zone

Hey all, I got it fixed.
I downloaded Visual Studio C++ compiler and it started to work.
Thanks for the responses!
swampsoda
 
Posts: 2
Joined: Sun Sep 15, 2019 12:06 pm

Wed May 13, 2020 7:50 pm Change Time Zone

Hello!
I know this is old but I'm getting the same exact behavior right now.
And yes, I selected "Thor" and I still get "Local" stuff.
I can select anything I want in the "Target" dropdown (roxie, thor, thor_roxie, hthor), but it doesn't seem to matter, it's stuck to "Local" somehow.

I was working off 6.4 when I decided to upgrade. I installed 7.8.8-1 (server is 7.8.6-1) and since then I'm stuck in "Local" mode. I tried uninstalling it and going down couple versions, but still stuck.

Any tips what I could be looking at? (logs?? some Microsoft C++ dependencies??)


Thanks for the help!
lpezet
 
Posts: 67
Joined: Wed Sep 10, 2014 3:14 am

Wed May 13, 2020 8:46 pm Change Time Zone

Hello lpezet,

I have seen cases before where this could be caused by a bad ECL IDE install or connectivity issues with the cluster.

At this point in time, and based on the details you have provided so far, I would suggest you to setup a configuration within your current ECL IDE to the playground (play.hpccsystems.com) and give it a try with a simple code. Note that the playground is currently setup to use SSL.

Let us know how it goes.

HugoW
hwatanuki
 
Posts: 10
Joined: Mon Apr 15, 2019 1:22 am

Wed May 13, 2020 9:12 pm Change Time Zone

Hi HugoW!

I just tried. It managed to connect to the cluster I believe (otherwise I'd get that "Unable to communicate with server" error).
I used the code from ECL Playground (the dataset with 3 people in it) and still no luck: it doesn't submit anything remotely, just stays "local".

I'll look into uninstalling and installing different versions (again) then.

Thanks!
lpezet
 
Posts: 67
Joined: Wed Sep 10, 2014 3:14 am

Thu May 14, 2020 6:50 pm Change Time Zone

I believe I've figured it out.

I used command line to run eclcc.exe manually. When doing so, it complained MSVCR120.DLL was missing. I had Microsoft Visual C++ 2015-2019 installed (and I probably uninstalled earlier version) but Microsoft Visual C++ 2013 is needed.

Once I installed Microsoft Visual C++ 2013 I was back in business.
lpezet
 
Posts: 67
Joined: Wed Sep 10, 2014 3:14 am


Return to ECL IDE

Who is online

Users browsing this forum: No registered users and 1 guest

cron