Mon Oct 22, 2018 9:32 am
Login Register Lost Password? Contact Us


Unable to open multiple builder windows in IDE (6.4.22)

Topics specific to the use of the ECL IDE

Mon Jul 30, 2018 3:08 pm Change Time Zone

Hi,

A work colleague is training using a local VM setup.
She is unable to open multiple builder windows. Clicking 'New Builder Window' once the 1st builder window is up does nothing.

She can open multiple ECL files from her repository.
She can also create multiple workspaces, each one of which has a single binder window in it.

Err -any ideas? I thought it might be a permissions issue with here users->public->documents->HPCC Systems windows direcotry but its not that.

She's waiting for approval for her forum user to be created, but in the mean time...

Yours
Allan
Allan
 
Posts: 318
Joined: Sat Oct 01, 2011 7:26 pm

Mon Jul 30, 2018 6:45 pm Change Time Zone

Allan,

I just duplicated the problem in 6.4.24-1 but it worked fine in my older 6.4.16-1 ECL IDE so it looks like a regression. Time for a JIRA ticket, and see if anyone has a slightly older ECL IDE install to give your colleague.

HTH,

Richard
rtaylor
Community Advisory Board Member
Community Advisory Board Member
 
Posts: 1388
Joined: Wed Oct 26, 2011 7:40 pm

Mon Jul 30, 2018 8:01 pm Change Time Zone

The question is how SHOULD this work? The bug I fixed was that if you searched for an attribute file and it was already open in a tab, then we don't open a new one but open the existing one.

If you try to open the same attribute file in the repository directory, should it not have the same behavior?

Maybe we need to create a "duplicate" attribute option that adds "_1" or "_new" to the end?
dehilster
 
Posts: 3
Joined: Mon Dec 08, 2014 2:41 pm

Mon Jul 30, 2018 8:07 pm Change Time Zone

I will look into this. This was most likely introduced when I fixed the opening of duplicate existing attributes. Am working on a fix right now.
dehilster
 
Posts: 3
Joined: Mon Dec 08, 2014 2:41 pm

Tue Aug 14, 2018 7:04 pm Change Time Zone

Me too having the same issue. When i try to open new window first time it is opening. Later time it always pointing to first one. I am unable to open multiple new windows. Pleas help.
Satheesh_T
 
Posts: 1
Joined: Mon Apr 23, 2018 7:50 pm

Tue Aug 28, 2018 5:01 pm Change Time Zone

Same problem with me - i downloaded new version 6.4.24 and cannot open new builder window or click open and open a query from hard drive.

Also how to download previous version of ECL idE?
Neha merchant
 
Posts: 1
Joined: Tue Aug 28, 2018 4:56 pm

Wed Aug 29, 2018 3:20 pm Change Time Zone

The latest version of the IDE prior to 6.4.22 can be found here:

https://hpccsystems.com/download/archiv ... v=6.4.16-1

HTH,

Jim
JimD
 
Posts: 134
Joined: Wed May 18, 2011 1:35 pm


Return to ECL IDE

Who is online

Users browsing this forum: No registered users and 0 guests

cron