Tue Mar 26, 2019 2:27 pm
Login Register Lost Password? Contact Us


Issue with spray from first demo

Post questions specific to installation or configuration for the HPCC Systems platform

Fri Jan 04, 2019 3:10 pm Change Time Zone

Hi,

I recently installed the ECL IDE and the VM environment and was trying to go through the demo to learn the system. When I had reached the step; Spray the Data File to your Data Refinery (Thor) Cluster, I got this error:

Failed: Localhost address used in remote file name: '/var/lib/HPCCSystems/mydropzone/testfiles/2of12.txt'

I originally tried the spray with the file in the mydropzone/ directory but had the same error so tried to create a folder and go from there and had the same result.

Any help on what I can do from here would be greatly appreciated.

Thank you,
Chris
cmconnelly
 
Posts: 7
Joined: Fri Jan 04, 2019 2:16 pm

Tue Jan 08, 2019 4:36 pm Change Time Zone

Please provide the name of the documentation you were following.
gfortil
 
Posts: 2
Joined: Wed Oct 24, 2018 6:09 pm

Fri Jan 11, 2019 3:03 pm Change Time Zone

It was the Installing & Running the HPCC System under more examples, Roxie Example: Anagram2, Spray the data file to your data refinery (Thor) cluster.

It gives me the error after I attempt the spray.
cmconnelly
 
Posts: 7
Joined: Fri Jan 04, 2019 2:16 pm

Mon Jan 14, 2019 8:09 pm Change Time Zone

Chris,

I just followed the steps you provided and the file sprayed successfully on my VM.

The error message says you are using localhost. I access ECL Watch on my VM using this url:
http://192.168.56.102:8010/

Can you try using the URL displayed when the VM starts?

Jim
JimD
 
Posts: 141
Joined: Wed May 18, 2011 1:35 pm

Mon Jan 14, 2019 9:19 pm Change Time Zone

Hi Jim,

When I run the VM it gives me:
ECLWatch: http://:8010

Is this from some sort of network issue?
I followed the Running HPCC in a Virtual Machine documentation for installing the
HPCC systems image file, i have version 7.0.2-1.

Thank you,
Chris
cmconnelly
 
Posts: 7
Joined: Fri Jan 04, 2019 2:16 pm

Wed Jan 16, 2019 2:36 pm Change Time Zone

Hi Chris,

If you run "ifconfig eth1" can you get ip? Sometime it is slow for some VM to get ip the first time. If still can't get ip you can try to reboot one more time. If still can't get ip let us know your environment: Virtualbox version and host OS. And what is your network. Usually HPCC VM should start even the host is offline.
Also there is documentation about HPCC VM setup: "Running HPCC in a Virtual Machine"
Ming
ming
 
Posts: 23
Joined: Wed Dec 18, 2013 12:38 pm

Mon Jan 21, 2019 8:30 pm Change Time Zone

Hi ming,

reminder: i can upload to landing zone but cannot spray.
the message from a spray is:
Failed: Localhost address used in remote file name: '/var/lib/HPCCSystems/mydropzone/2of12.txt'


thank you for your suggestions but we can't figure out what to do. we can ping 127.0.0.1, 192.168.56.1 (this is the ip address assigned by the virtualbox DHCP server). So we believe that the local host is configured correctly.

It appears the dfuserver is unable to communicate with the cluster. Since there is only one machine, and we verified that the networks are working, we don't know how to go forward.

Thanks,
Chris
cmconnelly
 
Posts: 7
Joined: Fri Jan 04, 2019 2:16 pm

Tue Jan 22, 2019 2:27 pm Change Time Zone

Chris,
"When all else fails, punt." :)

I would suggest that you simply download the latest VM image from the portal and start over fresh with a new VM. Once that's working, remove (delete) this troublesome VM.

Although I have heard of a "missing IP" problem once before, it is very uncommon (perhaps a stray gamma ray hit your memory chip at exactly the wrong time?? :D).

HTH,

Richard
rtaylor
Community Advisory Board Member
Community Advisory Board Member
 
Posts: 1434
Joined: Wed Oct 26, 2011 7:40 pm

Tue Jan 22, 2019 3:59 pm Change Time Zone

Hi Richard,

Today I updated my virtualbox to the newest version and downloaded and setup the newest version of the virtual image (HPCCSystemsVM-amd64-7.0.6-1.ova) in the virtualbox manager. When I try to run it the box pops up, shows the virtualbox starting picture, and then goes black and nothing runs. I let it sit there for about 30 minutes and nothing happened. I also removed the old image (7.0.2-1) and then put it back in the virtualbox manager and tried to set it up again. That one will run but still does not give me an ip address.

I am running windows 10 [Version 10.0.17763.253]

Any ideas?

Thank you for your help,
Chris
cmconnelly
 
Posts: 7
Joined: Fri Jan 04, 2019 2:16 pm

Wed Jan 23, 2019 1:04 pm Change Time Zone

Hi Chris,
By default HPCC VM is configured to use network adapter 2 of the instance.
You can check from the instance "Settings" -> "Network" ->"Adapter 2". Make sure it is attached to "Host-only Adapter" and "Name" field should look like "VirtualBox Host-Only Ethernet Adapter" or "VirtualBox Host-Only Ethernet Adapter #2", etc. For Host-only network configuration of Virtualbox you can check from "Host Network Manager" and pick the adapter assigned to your VM instance, for example, VirtualBox Host-Only Ethernet Adapter #2", It should have Adpater (with ip) and DHCP Server (with ip) defined and enabled.

If these all looks right but eth1 does get ip (sudo ifconfig eth1) you can try "sudo dhclient eth1". In HPCC VM documentation we tell user to configure "Adapter 2" to avoid a warning or user can click "change the network setting" when see the warning.

If the host-only network doesn't work (You may try other non-HPCC VM instance with host-only nextwork to check) you can try bridge network which will get ip from you internet provider.

For the earlier message about spray, do you get ip for eth1? VM 127.0.0.1 can't be reached from Windows host. 192.168.56.1 sounds like your adapter ip which is not the VM instance ip. Again "sudo ifconfig eth1" will tell.

I run HPCC 7.0.6-1 VM on my Windows 10 pro and it is OK.

Let me your progress and I can work with you to resolve this issue.

Thanks
ming
 
Posts: 23
Joined: Wed Dec 18, 2013 12:38 pm

Next

Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests

cron