Thu Sep 19, 2019 2:39 pm
Login Register Lost Password? Contact Us


unable to compile any job due to std file.ecl errors

Topics specific to the use of the ECL IDE

Thu May 16, 2019 8:01 pm Change Time Zone

It is 7.2.10 the newest version - I just downloaded.
I am using GitLab.
LimianFang
 
Posts: 9
Joined: Wed May 15, 2019 7:11 pm

Thu May 16, 2019 8:18 pm Change Time Zone

Hi Richard,

I found out why. I uninstalled and reinstalled an older version of ECL. I switched back to 6.4.16 then the errors are gone.
The problem is the new ECL installation package and the std library comes with it. somehow someone added more arguments into the file.ecl script in the std library inside the installation package.

I dont know if anyone else has the issue with the newer version of ECL.
LimianFang
 
Posts: 9
Joined: Wed May 15, 2019 7:11 pm

Fri May 17, 2019 1:21 pm Change Time Zone

You can (and should) always use the latest ECL IDE.

However, you should also have versions of the HPCC Client Tools to match each environment you are going to use. When you connect to the server, the IDE will choose the version that best matches.

In your case, you could use the 7.2.10-1 version of the IDE and the 6.4.36 version of the Client Tools.

The IDE is designed to be backward compatible and supports multiple versions of Client tools.

HTH,
Jim
JimD
 
Posts: 145
Joined: Wed May 18, 2011 1:35 pm

Fri May 17, 2019 2:31 pm Change Time Zone

right. Thanks Jim!
I didn't know the differences among ECL client tool differences , now I do.
should I always use this old version of client tool in the future?
I hope there is some guide or reference for us so we know which version to use.
LimianFang
 
Posts: 9
Joined: Wed May 15, 2019 7:11 pm

Fri May 17, 2019 3:07 pm Change Time Zone

You can have multiple versions of Client Tools and the IDE will choose the best one to use.

There is no "guide" to which version to use because the rule of thumb is to use the matching versions. If you have the matching version installed, the IDE will sort it out automagically.

If you are accessing a 6.4.x platform deployment, you should install that version of client tools. Keep that version until you no longer need it (IOW, when you no longer need to connect to 6.4.x platforms). There is very little overhead in keeping older versions.

HTH,

Jim
JimD
 
Posts: 145
Joined: Wed May 18, 2011 1:35 pm

Previous

Return to ECL IDE

Who is online

Users browsing this forum: No registered users and 1 guest